atarionline.pl asap - what's da problem? - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1: CommentAuthormonsoft
    • CommentTime22 Jun 2013
     
    @Dracon
    "I jak? Fajny ten Mint, lepszy niż przereklamowane Ubuntu, nieprawdaż? :)"

    Dystrybujca Minta jest opearta glownie o Ubuntu + MATE desktop lub Cinnamon , chociaz ja mam oparta na Debianie (LMDE). Wez pod uwage ze Ubuntu to nie tylko desktop ale takze wersja serwerowa.

    Ogolnie z linuxem jest tak ze uzywa sie tego co ci najbardziej odpowiada, a ze gustow jest wiele, to i wiele jest dystrybujcji Linuxa :)
    • 2: CommentAuthor0xF
    • CommentTime27 Jun 2013
     
    Dracon: zainstalowałem pod tym Mintem PPA webupd8, z niego audacious 3.3.4 no i działa.

    Spróbuj tego:
    cd asap-3.1.4
    rm asapplug.so
    sudo make install-audacious
    • 3: CommentAuthordhor
    • CommentTime28 Jun 2013
     
    Chyba ktoś będzie musiał zrobić normalne PPA, z wtyką do zainstalowania jak krzemowi bogowie przykazali, przez apt-get install :)
    • 4:
       
      CommentAuthorDracon
    • CommentTime28 Jun 2013 zmieniony
     
    @Fox: zrobiłem jak przykazałeś i... zadziałało! :D

    $rm asapplug.so
    $sudo make install-audacious
    $asapplug.so
    $mkdir -p `pkg-config --variable=input_plugin_dir audacious` && install asapplug.so `pkg-config --variable=input_plugin_dir audacious`/asapplug.so


    Znowu gra i buczy tak jak się spodziewałem. Dzięksy no i popieram Dhora, że może warto to jakoś uelastycznić na przyszłość. :)

    Dziwne czemu to wcześniej nie chciało odpalać, ale na szczęście teraz jest (na razie) spokój. :)


    P.S. Czy to, że nie ma żadnych informacji o odtwarzanym utworze (autor/rok, itp.) pod Audacious jest OK?
    • 5: CommentAuthordhor
    • CommentTime29 Jun 2013
     
    Tylko się upewnię - czy do kompilacji wtyczki dla Audacious konieczne jest instalowanie xasm/mads?
    • 6: CommentAuthor0xF
    • CommentTime29 Jun 2013
     
    Dracon: zrobiłeś tak: skompilowales wtyczke dla starego audaciousa, zaktualizowales audacious, po czym zainstalowales ponownie już skompilowana wtyczke. Trzeba było ja skasować z katalogu asapa (tak jak Ci napisałem) lub skasować cały katalog asap-3.1.4 i rozpakowac ponownie. Poprawie skrypty kompilujace wtyczke, aby zabezpieczyć się przed taka sytuacja.

    Autor/rok: sprawdze.

    Dhor: jeśli kompilujesz z tar.gz to nie trzeba. Chyba że zrobisz "make clean".
    • 7:
       
      CommentAuthorDracon
    • CommentTime29 Jun 2013 zmieniony
     
    OK, nieporozumienie wynikło pewnie stąd, że założyłem iż każda (nowa) kompilacja automatycznie nadpisuje starą (albo nastąpi pytanie o to) a tu tak się nie działo... ;o
    A info o autorze/roku już widzę podczas odtwarzania. Fajnie. :)
    • 8:
       
      CommentAuthorDracon
    • CommentTime13 Nov 2013 zmieniony
     
    To znowu ja... Mam takie niewinne pytanie - czy w kolejnych wydaniach ASAP-a można liczyć także na wsparcie odtwarzacza QMMP? ;)
    Podejrzewam, że modyfikacja wtyczki nie będzie bardzo drastyczna (tzn. że coś z wersji na Audacious się przyda).



    Linki:

    ->link<-
    ->link<-
    ->link<-
    • 9: CommentAuthor0xF
    • CommentTime18 Nov 2013
     
    Pierwszy raz słyszę tę nazwę, więc raczej priorytet niski.

    Wersje minor Audacious są niekompatybilne, tutaj też tak jest?
    • 10:
       
      CommentAuthorDracon
    • CommentTime19 Nov 2013
     
    No wiesz... świat jest ogromny, trudno wszystko naraz ogarnąć... ;)
    Nie słyszałem o jakiejś "niekompatybilności", używam to zamiennie z audaciousem, w poprzednim poście dałem linki do kodu i opisu programu więc wiedza jest dostępna.
    Wydaje mi się, że skoro to podobne playery, to może nie musiałbyś płodzić wtyczki od absolutnego zera... A, że lubisz rozbudowywać swoje użytki graficzno-muzyczne, to pomyślałem czemu nie dać wsparcia temu sympatycznemu odtwarzaczowi.

    ->link<-

    ->link<-

    recenzent napisał:

    "Audacious and Qmmp function identically because they are both based on Winamp. However Qmmp has more features. It supports more esoteric media formats like chiptune, Musepack and midi plus it has plugins for Scrobbing on Last.fm, a lyrics plugin and cover plugin, to name a few."
    • 11: CommentAuthor0xF
    • CommentTime6 Dec 2013
     
    Lubię rozbudowywać, ale zwyczajnie na razie nie znajdę na to czasu.

    0xF:

    Wersje minor Audacious są niekompatybilne

    Miałem na myśli, że gdy wychodzi wersja Audaciousa x.y, muszę przerabiać kod, aby z nią działał. W ten sposób utrzymanie tylko tej jednej wtyczki kosztuje mnie sporo czasu. Jeśli miałbym taką robotę odwalać przy Qmmp, to dziękuję.

    Nie wiem, skąd przekonanie, że Qmmp jest podobny do Audaciousa? Rzut oka na kod nie wskazuje podobieństw. Chyba, że chodzi o to:

    recenzent:

    Audacious and Qmmp function identically because they are both based on Winamp

    Na tej zasadzie wszystkie komputerowe odtwarzacze muzyczne są podobne. :-D
    • 12:
       
      CommentAuthorDracon
    • CommentTime6 Dec 2013
     
    Skoro ten AUDACIOUS jest taki upierdliwy i czasochłonny we wspieraniu, to mam genialne rozwiązanie - przerzuć się na QMMP, może będzie lepiej. :]
    Rzut oka na ficzery odtwarzacza i chyba prezentuje się nieźle, co?
    Być może QMMP jest podobny nawet dlatego, że też jest lekki w używaniu i robi użytek ze skórek Winampa. ;)
    Poza tym jest mulitplatformowy (biblioteka QT, te sprawy...) więc pewnie straty po pierwszym wspomnianym może by nie było aż takiej (w wypadku przerwania supportu).

    Oczywiście rozumiesz, że gdybym był programistą i wiedział co i jak, to sprawę załatwiłbym bez pisania tutaj. Proste.
    Ale życie bywa nieprzewidywalne... ;D
    • 13: CommentAuthor0xF
    • CommentTime6 Dec 2013
     
    Piszemy na forum, więc może ktoś się wypowie w kwestii Audacious vs Qmmp?

    A inny ktoś zakoduje wtyczkę? ;)
    • 14:
       
      CommentAuthorDracon
    • CommentTime6 Dec 2013
     
    Ja liczę tutaj szczególnie na głos jednego z piewców Wolnego Oprogramowania, a przy tym muzyka - [Salva]Dhora.
    Oraz ew. na Bobera czy Monsofta, bo tak mi się kojarzy, że mają wieloletnie doświadczenie z Linuksem. :)

    Tu autor nie był jednogłośny...
    ->link<-
    • 15:
       
      CommentAuthorDracon
    • CommentTime15 Dec 2013
     
    • 16: CommentAuthor0xF
    • CommentTime16 Dec 2013
     
    ?
    • 17:
       
      CommentAuthorDracon
    • CommentTime16 Dec 2013
     
    !
    Lobbuję...
    ....masz w jednym tekście wykaz co toto potrafi. :P


    BTW.
    Nie moja wina, że taki autorytet muzyczny jak Dhor, tu nie raczył się wypowiedzieć - trochę szkoda. :|
    • 18:
       
      CommentAuthorDracon
    • CommentTime11 Jun 2014
     

    FoX:

    Gotowych binarek nie wrzucalem, bo co nowa wersja audacious to niezgodna z poprzednia.

    Otóż to. Nadeszła ta chwila, więc kompiluj ponownie, bo Audacious zamilkł... :(
    • 19:
       
      CommentAuthorDracon
    • CommentTime12 Jun 2014 zmieniony
     
    V3.5 wydana:
    ->link<-

    Niestety jak to już odkryłeś wcześniej, poz(a)mieniali coś jak zwykle. :(
    • 20: CommentAuthor0xF
    • CommentTime22 Jun 2014
     
    Dzięki za info, ale przystosowanie wtyczki do nowego Audacious z zachowaniem kompatybilnosci ze starymi wymaga trochę pracy. Mam już parę innych rzeczy w ASAP czekających na wydanie i nie chcę z tego powodu odkładać wydania o kilka tygodni.
    • 21: CommentAuthor0xF
    • CommentTime11 Jul 2014
     
    Przystosowanie do Audacious 3.5, a tym bardziej następnych wersji, przerasta moje zasoby.

    Jeśli ktoś ma ochotę to przejąć, proszę bardzo. W przeciwnym przypadku kończę support Audaciousa na 3.4.

    Próbowałem przekazać ekipie Audaciousa: ->link<- ale rokowania są marne.
    • 22:
       
      CommentAuthorDracon
    • CommentTime11 Jul 2014 zmieniony
     
    Wyrazy uznania za wieloletni support i ostatnią próbę porozumienia z autorami!!
    Jeśli jednak oni robią takie problemy, to może w taki razie warto przejść na ten Qmmp ? ;)

    Ewentualnie jaka inna muzyczna odgrywaczka pod Linuksem (w odmianie UBUNTU) umożliwia obecnie odtwarzanie małoatarowskich muzaków??? :o
    • 23: CommentAuthor0xF
    • CommentTime12 Jul 2014
     
    mmSAP - dedykowany odtwarzacz SAPów.
    Poza tym są linuxowe wtyczki ASAP do: VLC, XMMS, MOC oraz odtwarzaczy opartych o GStreamer 0.10 (najpopularniejszy to Rhythmbox).

    Jest też wtyczka do XBMC, ale oficjalne kompilacje XBMC pod Linux jej nie zawierają.
    • 24: CommentAuthor0xF
    • CommentTime12 Jul 2014
     
    W wyborze portu (nie tylko pod Linuxem) może pomóc ta tabelka.
    • 25:
       
      CommentAuthorvoy
    • CommentTime12 Jul 2014 zmieniony
     
    W tabelce brak portów ASAP-a na klasyczne Amigi, z PowerPC i MorphOS: ->link<- :)
    • 26:
       
      CommentAuthormiker
    • CommentTime12 Jul 2014
     
    Voy: umówmy się, że to pokłosie "Anti Atari Song"... ;)
    • 27: CommentAuthor0xF
    • CommentTime11 Sep 2014
     
    Autor Audacious podesłał łatę do ASAP dostosowującą go do Audacious 3.5. Ponieważ wydanie ASAPa nieprędko, oto jak jej użyć:
    - rozpakowujemy asap-3.2.0.tar.gz
    - pobieramy łatę asap-3.2.0.diff z ->link<-
    - wchodzimy do katalogu asap-3.2.0
    - wydajemy polecenie:
    patch -p 1 -i SCIEZKA_DO/asap-3.2.0.diff

    Powinniśmy ujrzeć:
    patching file audacious/asapplug.c
    patching file audacious/audacious.mk

    Po czym kompilujemy i instalujemy wtyczkę do Audacious.
    • 28:
       
      CommentAuthorDracon
    • CommentTime13 Sep 2014
     
    Nooo... trochę droga naokoło, ale... udało się! ZNOWU GRA! :D
    Dzięnx.
    • 29: CommentAuthormonsoft
    • CommentTime16 Sep 2014
     
    Patchowanie to standard w Linuxowym/Unixowym swiecie. Wez sobie jakikolwieg srpm, rozpakuj i zobaczy ile tam jest patchy ktore podczas procesu budowania rpm'a sa uzywane. Tak oficjalnie robi sie zmiany w source rpm :)
    • 30:
       
      CommentAuthorDracon
    • CommentTime17 Sep 2014
     
    Liczę na to, że w kolejnych wersja Audaciousa również będą grały atarowskie muzaki (oby!). :)
    • 31: CommentAuthorAmun-Ra
    • CommentTime17 Sep 2014
     
    @monosoft, jednak patche do pakietów są stosowane w zupełnie innym celu. Nie są związane z brakiem stabilnego API.
    • 32:
       
      CommentAuthorDracon
    • CommentTime17 Sep 2014 zmieniony
     
    A może "patchowaniem" można by nazwać samo uaktualnianie kernela w linuchu? ;o
    Nie znam się, po prostu używam. :]
    • 33: CommentAuthormonsoft
    • CommentTime17 Sep 2014 zmieniony
     
    @Amur-Ra: Ja tam nie wiem jak to sie akurat ma w sutuacji Audacious. Pewnie autorowi latwiej bylo zapodac patcha niz robic nowe wydanie.

    My np uzywamy patchy do poprawek bezpieczenstwa w srpm'ach ktore uzywaja nasze servery (system niedostepny publicznie, aczkolwieg zgodny z open source i certyfikowany przez OSRB).
    Oczywisce mozna tez rozpakowac tgz'ta ktory jest w srpm i tam poprawic a pozniej spakowac. Ale jakos patch jest latwiejszy no i latwiejszy do usuniecia jesli cos jest nie tak.

    @Dracon: Patche zazwyczaj maja na celu poprawienie czegos co juz jest w kodzie no i zazwyczaj sa male. Jak robisz uaktualnienie to wielu wypadkach nowa wersja np. kernela dodaje calkiem nowe funkcje, ktore nie istnialy we wczsniejszej wersji.


    Aczkolwieg nie kazdy musi sie zgodzic z moim rozumowaniem.
    • 34:
       
      CommentAuthorDracon
    • CommentTime11 Apr 2015
     
    Ostatnio pod Linuksem była jakaś aktualizacja Audaciousa lecz dla mnie nieudana, bo coś nie tak było z tzw. zależnościami i musiałem wrócić do starszej wersji.
    A jak się sprawy mają z wtyczką do w/w programu? Nadal zostaje patch-owanie czy po staremu i lepszemu?
    • 35: CommentAuthor0xF
    • CommentTime12 Apr 2015
     
    Źródła wtyczki do Audacious 3.5 są w Git, jednak łatwiej będzie przez asap-3.2.0 i łatę.
    • 36: CommentAuthorlemiel
    • CommentTime2 Oct 2015
     
    A już miałem narzekać, że asap źle odtwarza się po instalacji wtyczki gstreamera, a tu audacious go nie używa.
    Dociągnięcie audacious-dev, patcha i według instrukcji jw. zadziałało.
    Dzięki.
    • 37:
       
      CommentAuthorDracon
    • CommentTime19 Apr 2017 zmieniony
     
    To znowu ja. Siedzę sobie obecnie na Mincie 18.1 KDE 64-bit i próbuję znów "ucywilizować" AUDACIOUS'a (aktualnie w wersji 3.8.2). Dziwię się bardzo, że wciąż nie ma tam standardowo dołączonej wtyczki ASAP, za to (oczywiście) jest "Odtwarzacz SID". :O
    Ze strony ASMY ściągnąłem sobie paczkę z ASAP i zacząłem kompilować wtyczkę. Nie może być "za dobrze" i nie udało mi się uzyskać zadowalającego wyniku.
    W terminalu są takie komunikaty:
    ~/Pobrane/asap-3.2.0 $ make asap-audacious
    asapplug-3.8.2.so
    audacious/asapplug.c:27:30: fatal error: audacious/plugin.h: No such file or directory
    #include <audacious/plugin.h>
    ^
    compilation terminated.
    audacious/audacious.mk:18: polecenia dla obiektu \'asapplug-3.8.2.so\' nie powiodły się
    make: *** [asapplug-3.8.2.so] Błąd 1


    Przy próbie kompilacja dla playera VLC mam podobnie:
    ~/Pobrane/asap-3.2.0 $ make asap-vlc
    libasap_plugin.so
    vlc/libasap_plugin.c:30:24: fatal error: vlc_common.h: No such file or directory
    #include <vlc_common.h>
    ^
    compilation terminated.
    vlc/vlc.mk:23: polecenia dla obiektu \'libasap_plugin.so\' nie powiodły się
    make: *** [libasap_plugin.so] Błąd 1



    WTF? :o
    Nadmieniam, że "audacious-dev" jak i "gtk+-3.0" mam zainstalowane.
    • 38: CommentAuthorAmun-Ra
    • CommentTime19 Apr 2017
     
    @Dracon

    W Debianie do vlc_common.h potrzeba libvlccore-dev.
    audacious/plugin.h powinno siedzieć w /usr/include więc powinno działać bez dodawania ścieżki. Sprawdź czy rzeczywiście tam jest i jeśli jest gdzieś indziej dodać ścieżkę za pomocą -Iścieżka (chodzi o katalog nadrzędny do katalogu audacious z plikiem plugin.h). Podobnie z vlc_common.h.
    • 39:
       
      CommentAuthorDracon
    • CommentTime20 Apr 2017 zmieniony
     
    @Amun-Ra:
    Wielkie dzięki za odzew!

    Sprawdziłem i plik "plugin.h" (związany z Audaciousem) siedzi sobie w
    /usr/include/libaudcore/

    - czy możesz podać jak to konkretnie wpisać/powiązać?


    Co do VLC, zainstalowałem tę bibliotekę, która wspominałeś i mam takie coś:
    ~/Pobrane/asap-3.2.0 $ make asap-vlc
    libasap_plugin.so
    vlc/libasap_plugin.c: In function \'Open\':
    vlc/libasap_plugin.c:176:6: warning: implicit declaration of function \'stream_Read\' [-Wimplicit-function-declaration]
    if (stream_Read(demux->s, module, module_len) < module_len) {


    ... może jak się nauczę jakoś "dowiązywać" te pliki *.h, to będzie inny rezultat... :|
    • 40: CommentAuthor0xF
    • CommentTime20 Apr 2017
     
    Nowe wersje Audacious i VLC wymagają aktualizacji wtyczek.

    Wtyczka ASAP do Audacious zatrzymała się na Audacious 3.5, więc ją sobie odpuść.

    Błąd kompilacji wtyczki VLC został już poprawiony w zeszłym roku, ale nie było od tego czasu wydania ASAP. Zastąp plik vlc/libasap_plugin.c tym: ->link<- i wtedy powinno się skompilować.
    • 41:
       
      CommentAuthorDracon
    • CommentTime25 Apr 2017 zmieniony
     
    OK, poprawkę pobrałem i zainstalowałem - niby wszystko poszło poprawnie:
    ~/Pobrane/asap-3.2.0 $ make asap-vlc

    libasap_plugin.so

    ~/Pobrane/asap-3.2.0 $ sudo make install-vlc

    mkdir -p /usr/local/lib/vlc/plugins/demux && install libasap_plugin.so /usr/local/lib/vlc/plugins/demux/libasap_plugin.so


    Jednakże przy próbie otwarcia pliku muzycznego w VLC, dostaję taką odpowiedź:
    Twoje dane wejściowe nie może być otwarte:
    Program VLC nie może otworzyć MRL \'file:///home/myname/Muzyka/Wodospadem_Czasu.sap\'. Szczegóły błędu można znaleźć w dzienniku.


    (Otwieram przez "Wszystkie pliki" bo jako "audio" sie nie da). Dziennik zaś mówi:
    avformat error: Could not open /home/myname/Muzyka/Wodospadem_Czasu.sap: Unknown error 1094995529
    ps error: cannot peek
    core error: cannot parse file:///home/myname/Muzyka/Wodospadem_Czasu.sap


    VLC wersja: 3.0.0-git Vetinari

    :O




    A co do AUDACIOUSa, to czy nie ma co się spodziewać "odnowionej" wersji wtyczki???
    • 42: CommentAuthor0xF
    • CommentTime26 Apr 2017
     
    Prawdopodobnie zainstalowałeś w niewłaściwym katalogu.

    1. Zobacz, czy tam gdzie instalowałeś, są inne wtyczki VLC:
    ls -l /usr/local/lib/vlc/plugins/demux

    2. Może jednak są tu?
    ls -l /usr/lib/vlc/plugins/demux

    3. Jeśli tak, to instalujesz tak:
    sudo make install-vlc VLC_DEMUX_PLUGIN_DIR=/usr/lib/vlc/plugins/demux
    • 43:
       
      CommentAuthorDracon
    • CommentTime26 Apr 2017 zmieniony
     
    2. Może jednak są tu?
    ls -l /usr/lib/vlc/plugins/demux

    Tak!

    3. Jeśli tak, to instalujesz tak:
    sudo make install-vlc VLC_DEMUX_PLUGIN_DIR=/usr/lib/vlc/plugins/demux

    Udało się! Gra i buczy! :)))

    Dobre i to, choć wciąż liczę, że i na tym "drugim" też kiedyś jeszcze ruszy... ;)
    • 44: CommentAuthor0xF
    • CommentTime27 Apr 2017
     
    Super!

    Wersje Audaciousa różniące się o 0.1 mają całkiem niezgodny interfejs dla wtyczek. Dostosowanie do nowej wersji to praktycznie napisanie wtyczki od zera. Dodatkowym problemem jest to, że użytkownicy mają różne wersje Audaciousa i napisanie wtyczki tak, aby była zgodna z różnymi wersjami jest karkołomnym zadaniem. Spędziłem już na tym długie godziny i mam dosyć.
    • 45: CommentAuthorzyga64
    • CommentTime8 May 2017 zmieniony
     
    Witam. Mam pytanie do autora.

    Czy jest szansa na plugin do programu DeaDBeaF ->link<- ?

    To zdobywający ostatnio popularność "lekki" player dla linuxa. Taki zamiennik windowsowego Foobara.