atarionline.pl eclipse + wudsn - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1:
       
      CommentAuthorat0mic
    • CommentTime15 Mar 2012
     
    czy udało się komuś ściągnać wudsn do eclipse?

    na stronie wudsn.com jest paczka ze wszystkimi popularnymi assemblerami, romy atari, linki do gołego eclipse ale działającej linki do wudsn nie znalazłem.

    jest wspaniała instrukcja jak instalować i konfigurować tę wtyczkę, więc może ktoś ma działającego linka albo może zamieścić to co kiedyś ściągnał ze strony wudsn.com ?
    • 2: CommentAuthorEagle
    • CommentTime15 Mar 2012 zmieniony
     


    W Help -> Install new sofware

    wklej:
    http://www.wudsn.com/update


    Powinno działać.
    • 3: CommentAuthortEDDYbOAR
    • CommentTime15 Mar 2012
     
    działa zgodnie z instrukcją instalacji na stronie wudsn
    • 4:
       
      CommentAuthorat0mic
    • CommentTime2 Apr 2012 zmieniony
     
    kompiluje się pod MADS/KickAss' a żeby było śmieszniej to moim ulubionym KickAssemblerem mogę kompilować na Atarkę - to najlepszy turboassembler na 8bit (autor KICK'a nazywa się MADS - więc kiedyś myślałem że MADS i KICK to to samo)

    niestety skompilowaną binarkę trzeba wczytać do pamięci emulatora samemu z poziomu monitora ponieważ nie zawiera koniecznych w XEX danych - ot i się nie przydaje niestety do A8...

    na x86 najwygodniejszy jest według mnie FASM Tomasza Grysztara jakby ktoś pod Linux/Unix a nawet WIN64bit chciał coś napisać w assemblerze - dzisiejsze procki mają takie rozkazy że to prawie HLA - niemalże bliskie C
    • 5:
       
      CommentAuthorxeen
    • CommentTime20 Aug 2013
     
    jak w WUDSN używam procedur madsowych, w których zmienne są zadeklarowane jako przekazywane prze rejestry to przy wywołaniu procki bez ich podawania środowisko wyświetla mi warning: improper number of parameters. Szlag człowieka trafia bo środowisko zawsze skacze do takich warningów po kompilacji. Da się tak wtyczkę skonfigurować, aby je ignorowała? Of coz w propertisach tego warninga nie ma.
    • 6:
       
      CommentAuthormgr_inz_rafal
    • CommentTime20 Aug 2013 zmieniony
     
    Spróbuj w miejscu wywołania dodać przecinek, np.:

    funkcja ,

    lub

    funkcja , ,


    w zależności od ilości parametrów.