atarionline.pl ast multi cardridge - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1: CommentAuthoratariki50
    • CommentTime20 Jan 2017 zmieniony
     
    Mam problem z uruchomieniem obrazu "bin" kartridża AST Multi Cartridge. Taki wypasiony AST :) Może ktoś podeśle wersję "xex" Albo powie co robię źle? lub poda namiary na poprawny plik? Jedyne źródło które znalazłem to:
    ->link<-

    Zależy mi na tym pliku. Wiem że działało pod emulatorami z opcją PHOENIX 8k ale po wybraniu pliku "bin" w menu nie ma takiej opcji, a inne nie działają :(( Ma ktoś poprawny plik?
    byłbym wdzięczny. Plik z naszych zasobów AST v2.room działa.
    Ale to wcześniejsza wersja.
    • 2: CommentAuthorseban
    • CommentTime20 Jan 2017 zmieniony
     
    Cześć!

    Plik jest jak najbardziej poprawny. Tylko żaden z emulatorów oprócz Atari800 nie wspiera chyba emulacji tego typu cartridge (trzeba zapytać kolegę Krótkiego). Obrazu tego cartridge nie da się uruchomić bez znaczących przeróbek jako plik .xex. Nie mówię że to jest nie możliwe, jednak wymagało by pewnego nakładu pracy.

    W wątku do którego link podałeś dokładnie opisałem zasadę działania tego cartridge. Nie jest to typowy cartridge i sądzę iż celowo został w ten sposób zaprojektowany. Z jednej strony jako rozwiązanie nietypowe stanowił swego rodzaju zabezpieczenie przed przerobieniem tego na inną formę (np. binarną) z drugiej strony dawało autorowi rozwiązania masę miejsca w pamięci, ponieważ obszar $8000-$BFFF) był wolny i można było mieć w tym miejscu RAM, a jednocześnie można było mieć cały czas dostęp do pamięci EPROM obecnej w cartridge... (okno pamięci o rozmiarze 256 bajtów umiejscowione w lokalizacji $D500-$D5FF).

    Efekt końcowy był taki że każdy zapis pod adres $D5xx powodował zwiększenie licznika adresującego górne 8-bitów pamięci EPROM.. co dawało 256 sektorów (256 bajtowych) widocznych w tym obszarze. A więc cała zawartość 64KB EPROM-u była możliwa do zaadresowania bez zajmowania jakiegokolwiek obszaru w pamięci RAM komputera.
    • 3: CommentAuthorGzynio
    • CommentTime20 Jan 2017
     
    W związku z tym że był to nietypowy cartridge nie chciały one uruchamiać się na XEGS-ach. Na zwykłych modelach podobno nie było tego problemu. Ja musiałem do nich jechać drugi raz i wymieniać go na zwykły cartridge który dopiero działał poprawnie na z XEGS-em.
    • 4:
       
      CommentAuthorKrótki
    • CommentTime21 Jan 2017
     
    Dla AST Multicartridge'a trzeba wybrać typ kartridża "AST 32K", jak nie masz takiej opcji to wymień emu na nowse Atari800 lub Altirrę. Ale używanie tego kartridża nie ma sensu w emulatorach - tylko Atari800-a8cas obsługuje kasety turbo, ale dość słabo i tylko odczyt.
    • 5:
       
      CommentAuthorvoy
    • CommentTime21 Jan 2017 zmieniony
     
    Mimo że słabo, to i tak odczyt ładnie działa. :)

    Marzy mi się możliwość zapisu w turbo. Niedawno preparowałem dla znajomego kasetę w dolnośląskim Turbo 2000 i pozostała właściwie tylko możliwość wygenerowania takowej pod Turgen System Baktry. Dostępny jest tam tylko standardowy loader Auto Turbo i przerobiony loader z kopiera "Unknown Exterminator" Tomasza Rolewskiego, a pozostałe kopiery tego pana oferowały całą gamę różnych typów loaderów, łącznie z tymi w normalu, z wydłużonymi przerwami między blokami, czy nawet w trybie Turbo 3000 (podkręcone procedury odczytu i zapisu, czyli większa szybkość).

    Gdyby istniał w Atari800-a8cas choćby zapis do turbo do CAS, byłbym w siódmym niebie. :) Wiele moich kaset w turbo ma specyficzne loadery, utrudniające ich kopiowanie i trzeba je wczytać do programów typu Crazy Renounce, gdzie można je zapisać w postaci odbezpieczonej, ale z kolei nie ma możliwości zapisu danych na dysk. Pozostaje wczytanie takiego nagrania w formie WAV do kopiera, zrzut pamięci w monitorze emulatora i wydłubywanie danych z bufora kopiera z tego zrzutu.

    To samo dotyczy możliwości wczytywania w dolnośląskim Turbo 2000 nagrań z loaderem w normalu i pozostałymi danymi w turbo (dla samego turbo trzeba ustawić tryb Manual).
    • 6: CommentAuthoratariki50
    • CommentTime22 Jan 2017 zmieniony
     
    Voy Baktra robi dobrą robotę. Ale faktycznie masz rację. Ja też bym chciał.
    Co do opcji 32k to przerabiałem temat nie działa. Mam najnowsza Altirę. Patrzyłem też starsze,nic.
    • 7: CommentAuthoratariki50
    • CommentTime22 Jan 2017
     
    seban. dzięki za wytłumaczenie tematu. Pamiętam że odpaliłem to ustrojstwo pod emu. Jeśli plik jest OK to się jeszcze trochę z nim pomęczę :) Dzięki.
    • 8:
       
      CommentAuthorbaktra
    • CommentTime23 Jan 2017
     
    [To samo dotyczy możliwości wczytywania w dolnośląskim Turbo 2000 nagrań z loaderem w normalu i pozostałymi danymi w turbo (dla samego turbo trzeba ustawić tryb Manual).]

    Opcja "Turbo System: Atari Super Turbo (XC12)" nie działa?
    • 9: CommentAuthorFUJI
    • CommentTime24 Jan 2017
     

    Voy:

    Marzy mi się możliwość zapisu w turbo.


    Ja mam łatki do liba8cas i a800, które dodają możliwość zapisu turbo do plików wav, ostatnio odświeżane 2 lata temu, więc pewnie trzeba by znów dostosować do obecnej wersji. Zapis bepośrednio do .cas wymagał by dopisania całego dekodera turbo.
    • 10:
       
      CommentAuthorvoy
    • CommentTime27 Jan 2017
     
    @baktra: masz rację, działa w trybie AST. :)

    @FUJI: byłoby naprawdę super, nawet gdyby był tylko zapis do WAV. O zapisie do CAS nie śmiem marzyć, choć byłbym wielce kontent z zaistnienia takowej opcji. :)
    • 11: CommentAuthoratariki50
    • CommentTime27 Jan 2017 zmieniony
     
    voy
    krok po kroku :).
    A może by tak zebrać doświadczenia użytkowników w jeden temat?
    FUJI by coś dołożył.
    • 12: CommentAuthoratariki50
    • CommentTime30 Jan 2017
     
    Widzę że cisza. Trudno, powalczę z czasem i przeciwnościami to się odezwę.
    • 13: CommentAuthorFUJI
    • CommentTime31 Jan 2017
     
    Daj mi chwilę, muszę dostosować patcha do aktualnej wersji *a8cas. Na szczęście (albo na nieszczęście) od dwóch lat niewiele było zmian w kodzie atari800.
    • 14:
       
      CommentAuthorbaktra
    • CommentTime31 Jan 2017
     
    Nie mogę się doczekać
    • 15: CommentAuthorFUJI
    • CommentTime1 Feb 2017 zmieniony
     
    @atariki50 - zdaje się, że masz problem w ogóle z uruchomieniem tego cartridge-a. Ja się dziś też przez chwilę męczyłem, chociaż kiedyś go już uruchamiałem. Zajrzałem więc do instrukcji. Trzeba uruchamiać komputer (albo emulator) z wciśniętym SELECT.

    Na poprawki patchy potrzebuję jeszcze troszkę czasu, co nieco trzeba jednak poprawiać ręcznie.

    Edit:
    Dla niecierpliwych - daję coś co działa, przynajmniej w zakresie związanym z tym wątkiem. Uprzedzam, że niewiele posprawdzałem i na pewno są bugi. Np. włączenie opcji nagrywania taśmy z włączonym systemem turbo powoduje niezamierzoną permanentną aktywację turbo i zapis w normalu nie wychodzi (trzeba wyłaczyć turbo przed zapisem w normalu). Ale przetestowałem działanie z tym multicartem AST i np. można skopiować z normal na turbo do pliku wav, a potem z tego pliku wav wczytać z powrotem (funkcja unichanger).

    Oprócz samego zapisu do wav jest dodana obsługa kilku systemów turbo. Będę powoli sprawdzał co działa a co nie i poprawiał w miarę możliwości. W międzyczasie były oficjalne zmiany w kodzie emulacji PIA, a tam są rzeczy ważne dla obsługi np. turbo 6000 i turbo 2000 podłączanego przez port joysticka. Jak ktoś ma czas to niech potestuje i da znać co nie działa.

    Patche są do najświeższych wersji liba8cas i atari800-a8cas z repozytoriów git.
    Pliki:
    - patch do liba8cas: ->link<-
    - patch do atari800-a8cas: ->link<-
    - źródła liba8cas załatane: ->link<-
    - źródła atari800-a8cas załatane: ->link<-

    Skompilować trzeba samemu. Ewentualnie mogę dorzucić skompilowane pod linuxa 64bit.

    Jak ktoś się przyjrzy, to widać, że są też dodane funkcje zapisu turbo do plików cas i hex, ale niestety brakuje najważniejszego, czyli dekodera wav -> cas/hex.
    • 16: CommentAuthoratariki50
    • CommentTime1 Feb 2017
     
    FUJI
    Jest tak jak napisałeś. Chętnie poczekam. Powodzenia. A z tym klawiszem SELECT toś mnie zastrzelił. Matko z córką toć ATARI czy emulator klawisze funkcyjne posiada :)).Dzięki. Czekam, czekamy :) na efekty Twojej pracy.
    • 17: CommentAuthormono
    • CommentTime2 Feb 2017
     
    Rewelacja! Będzie turbo w atari800 :)
    • 18: CommentAuthoratariki50
    • CommentTime2 Feb 2017
     
    FUJI
    Wielkie dzięki.
    Proszę pracuj dalej.
    Spoko😊 odświerzę temat.
    Myślę że wielu zależy na twojej PRACY tylko się jakoś wstydzą pisać czy co🤔 Ludzie tu się kroi coś fajnego. Dajcie odzew proszę.
    • 19:
       
      CommentAuthorvoy
    • CommentTime3 Feb 2017
     
    @FUJI: super, dzięki! :) A jak wygląda zapis nagrań hybrydowych (loader w normalu + reszta w turbo)? Parę kopierów z dolnośląskiego Turbo 2000 oferuje takowy.
    • 20: CommentAuthorFUJI
    • CommentTime4 Feb 2017 zmieniony
     
    Już działa, voy. Tu masz np. zapisany za jednym zamachem program ze znanego Ci Plaza Copiera:
    ->link<-

    a tu loader Auto Turbo z generatora loadera:
    ->link<-

    BTW: Plaza Copier wymaga włączenia SIO patcha przy odczycie z dyskietki (nie chce czytać bez patcha SIO, nie moja wina), a zapis na kasetę wymaga wyłączenia tegoż (na razie nie planuję zapisu do wav z włączonym patchem SIO).

    Uaktualnione linki (te same co powyżej, zawartość trochę inna):
    ->link<-
    ->link<-
    ->link<-
    ->link<-

    Dodałem dodatkowe systemy, które zapisują w trochę inny sposób (sterowanie bitem 3 SKCTL zamiast bitem 7). Z punktu widzenia prawdziwego magnetofonu to nie ma znaczenia, ale dla emulatora ma. W emulatorze brakuje globalnej zmiennej, która by pokazywała zawsze aktualny stan linii data-out zależny od różnych czynników, więc mnożę opcje. Np. są teraz dwa warianty czechosłowackiego turbo 2000, bo niektóre programy zapisują tak a inne siak.
    • 21:
       
      CommentAuthorvoy
    • CommentTime5 Feb 2017
     
    Przetestowałem z dolnośląskim Turbo 2000 i działa świetnie, choć są problemy z trybem Turbo 3000 (podkręcone procedury zapisu i odczytu).

    Ogólnie jest super. :)
    • 22:
       
      CommentAuthorvoy
    • CommentTime5 Feb 2017
     
    Dzięki uprzejmości FUJI'ego mamy też już port pod Windowsa. :)
    • 23: CommentAuthoratariki50
    • CommentTime7 Feb 2017
     
    FUJI
    Wielkie dzięki. Kawał dobrej roboty. Mam tylko jedno pytanie, nie denerwuj się :) Czy turbo UM też jest obsługiwane? ->link<-
    Przepraszam nie mam teraz czasu na testy :(( Odpowiedz proszę. Testy dopiero w weekend :(
    • 24: CommentAuthorFUJI
    • CommentTime7 Feb 2017
     
    Zapis UM działa, np. z wybranym systemem AST. Tylko potem odczyt wymaga odwrócenia fazy sygnału. Hmmm...
    W najgorszym wypadku można odwrócić w edytorze audio ;).

    Testowałem też trochę turbo 6000. Ogólnie działa, choć jeden program to samo nagranie czyta poprawnie a drugi nie...
    • 25: CommentAuthoratariki50
    • CommentTime8 Feb 2017
     
    FUJI
    Dzięki za port pod Windę.
    Rozumiem że trzeba jeszcze troszkę to dopracować ;).
    Ale ważne że w końcu, dzięki Tobie coś ruszyło.
    Nie rozumiem natomiast dlaczego tu nie ma 100 postów z pytaniami do autora?

    Na turbo UM cholernie mi zależy, ze względów sentymentalnych ;). Całe noce, kumple itd. 20-lat temu :(.
    • 26: CommentAuthoratariki50
    • CommentTime8 Feb 2017
     
    Tak przy okazji z tego co wiem i pamiętam. Turbo AST jest zgodne z UM i ATT sprzętowo. Chociarz płytki tych systemów różnią się użytymi do budowy scalakami. Sposó podłączenia jest ten sam, dodatkowy przewód we wtyczce SIO. Resztę powinno załatwić oprogramowanie. Ale tu pamiętam że miałem problemy z turbo UM na przerubce AST. Niby chodziło ale nie do końca poprawnie. Wymiana płytki AST na UM załatwiła sprawę. Pod kontrolą przeróbki UM wszystkie programy AST,ATT,Normal śmigały aż miło. Może trzeba by się bliżej przyjżeć zapisowi UM? To jednak nie AST chociaż większość tak uważa.
    Jeszcze jedno. Pod UM jest kopier zdolny przekonwertować program w AST ATT innych nie testowałem na turbo UM. Wszystko działa potem pod loaderem UM.
    Myślę że warto by dodać do emulatora opcję turbo UM osobno. Gdyby się dało oczywiście :).

    FUJI
    Pomyślisz o tym ?
    Było by jedwabiście ;).
    • 27: CommentAuthorFUJI
    • CommentTime8 Feb 2017
     
    Odwróciłem polaryzację przy zapisie AST/ATT/UM (zdaje się że było źle), AST to nie przeszkadza a UM pomaga. Dodałem za to do menu nowe opcje pozwalające odwrócić polaryzację przy zapisie i przy odczycie dla dowolnego systemu turbo, gdyby było potrzeba. W związku z tym zniknęła z listy pozycja "Manual switch, reverse signal". Dodałem do menu systemy ATT i UM - działają identyczne jak AST, ale nie każdy korzystający z emulatora musi to wiedzieć. Można już też zapisywać Hard Turbo.
    Do ściągnięcia:
    źródła liba8cas
    źródła atari800-a8cas
    binaria dla Windows
    • 28: CommentAuthoratariki50
    • CommentTime9 Feb 2017
     
    Dzięki FUJI

    Szkoda że już rozebrałem choinkę. Byłby fajny prezent na gwiazdkę :). A może ubiorę zpowrotem, pstawię pod nią lapka z odpalonym emulatorem i będę pokazywał wszystkim panom "NIEDASIĘ" że jednak można?, zobaczę ;).
    Naprawdę bardzo się cieszę że podjąłeś temat.
    Od dzisiaj "FUJI" to moja ulubiona firma :)
    Gdybyś w nagłym przypływie veny i wolnego czasu oczywiście, zechciał dalej rozwijać swoje pluginy do emulatora to masz wiernego fana swojej pracy.
    Dobra bo przesłodzę ;).
    Jeszcze raz Wielkie Dzięki!
    • 29: CommentAuthorFUJI
    • CommentTime12 Feb 2017
     
    Dzięki za uznanie, ale większość podziękowań należy się Krótkiemu, bo bez niego nie było by tego w ogóle. Ja przeważnie robiłem copy/paste + trochę zmian.

    Małe uaktualnienie:
    - naprawiłem podsłuch dźwięku przy wczytywaniu kaset turbo (obrzydliwie przerywał przez ostatnie lata)
    - naprawiłem Blizzarda, działa świetnie nagrywanie i odtwarzanie
    - częstotliwość dźwięku nagrań jest ustawiana na taką, jaka jest w ustawieniach emulatora, zmiast stałego 44.1 kHz

    źródła liba8cas
    źródła atari800-a8cas
    binaria dla Windows

    Jedno co za nic nie chce mi działać jak należy to AST w wersji dla magnetofonu 1010, sporo szybsze od "normalnego" AST. Nie wiem czemu, bo na oko prędkość jest mniej więcej taka jak Blizzarda. To znaczy działa, ale jak z rozklekotanym starym magnetofonem, tylko od czasu do czasu ;). Pewnie to samo dotyczy przyspieszonego turbo 2000, o którym wspominał Voy.
    • 30: CommentAuthoratariki50
    • CommentTime17 Feb 2017 zmieniony
     
    AST wersja dla 1010 to mała zagadka. Oficjalnie dostosowano prędkość turbo do nowych magnetofonów Atari serii XC12/XCA12 których "bebechy" nie wytrzymały sprzętowo transmisji dla 1010. Ale dla emulatora nie powinno to mieć większego znaczenia. Coś mi się wydaje że w kodzie terz zamieszano w stylu zgodny w dół. Tak więc AST 1010 to prawie to samo co "zwykłe" AST. Diabeł jak zawsze tkwi w szczegółach kodu. Programy turbo nagrane softem dla 1010 miały problemy z odczytem na XCA12.
    Może trzeba loadera od AST v.1010 ?
    • 31: CommentAuthoratariki50
    • CommentTime17 Feb 2017
     
    Krótki, przepraszam. FUJI troszkę :) mnie naprostował. Faktycznie, od twojego Atari800 się zaczęło.
    Nie gniewaj się :).

    Ale warto było ;)

    A może by tak połączyć wasze umiejętności?

    Wiem, wiem.

    Ale tego emulatora terz miało nie być ;).

    Dzięki Wam JEST !
    • 32: CommentAuthorFUJI
    • CommentTime17 Feb 2017
     
    Wiem już, dlaczego szybkie AST nie chce działać. Jest za szybkie ;D. Problem wynika z bardzo małych tolerancji szerokości impulsów odpowiadających bitom "0". A właściwie tolerancji szerokości połówek impulsów, bo AST mierzy tylko drugą połówkę. Otóż różnica między wymaganą minimalną i maksymalną wartością wynosi 22 cykle zegara (88-110), natomiast pomiędzy dwiema próbkami dźwięku przy częstotliwości próbkowania 64kHz mieści się 27.7 cyklu zegara. Widać od razu, że przy takiej częstotliwości próbkowania nie ma szans uzyskać stabilnego działania. Żeby chciało dobrze działać, musiało by być pewnie w okolicach 11 cykli zegara od sampla do sampla. To można by osiągnąć przy około 160kHz. Zastanawiam się jeszcze, w jaki sposób do tego podejść, bo mam wrażenie że emulator przy odczycie resampluje plik do ustawionej częstotliwości audio (max. 65535 Hz). Udało mi się obejść problem dla 64kHz (jeżeli nie całkowicie to w znacznym stopniu) przez kradzenie jednego sampla z pierwszej połówki impulsu i dodawanie go do drugiej, ale tak raczej nie mogę zostawić. Choć mógł bym powiedzieć, że to emulacja fluktuacji wytwarzanych przez tor zapisu/odczytu magnetofonu ;).

    A do Krótkiego na pewno się zgłoszę jak uznam że skończyłem ten etap (zapis do wav), choć się obawiam że sprawa znowu utknie przez brak czasu...
    • 33: CommentAuthoratariki50
    • CommentTime18 Feb 2017 zmieniony
     
    Brak czasu to moje drugie imię :). A popatrz co z tego wyszło :). Tak jak pisałem wcześniej, krok po kroku i dzieje się "niemożliwe" Spoko, przypilnuję tematu ;). "WAV"

    Co do AST1010.
    Może by spróbować znaleźć kontakt do twurców systemu? Jakiś wywiad mała retrospekcja?

    Czy ktoś kto to czyta zna namiary na twurców AST ???
    Fajnie by było powspominać a przy okazji jakieś konkrety by wyszły.
    • 34:
       
      CommentAuthorKrótki
    • CommentTime24 Feb 2017
     

    atariki50:

    Krótki, przepraszam. FUJI troszkę :) mnie naprostował. Faktycznie, od twojego Atari800 się zaczęło.
    Nie gniewaj się :).

    Ale nie ma za co.

    atariki50:

    A może by tak połączyć wasze umiejętności?

    Oczywiście. Jak będę miał wystarczająco dużo czasu, zintegruję zmiany FUJI'ego "do siebie". Już raz zresztą miałem to zrobić kilka lat temu, ale rozbiło się to o brak czasu.

    FUJI:

    Wiem już, dlaczego szybkie AST nie chce działać. Jest za szybkie ;D. Problem wynika z bardzo małych tolerancji szerokości impulsów odpowiadających bitom "0". A właściwie tolerancji szerokości połówek impulsów, bo AST mierzy tylko drugą połówkę. Otóż różnica między wymaganą minimalną i maksymalną wartością wynosi 22 cykle zegara (88-110), natomiast pomiędzy dwiema próbkami dźwięku przy częstotliwości próbkowania 64kHz mieści się 27.7 cyklu zegara.


    FUJI, skoro jak widzę zacząłeś rozgryzać wersję 1010 - czy jest szansa, abyś uzupełnił Atariki o opis różnic w stosunku do wersji XC12?

    FUJI:

    Zastanawiam się jeszcze, w jaki sposób do tego podejść, bo mam wrażenie że emulator przy odczycie resampluje plik do ustawionej częstotliwości audio (max. 65535 Hz).

    Jedyne co się resampluje to dźwięk do odtworzenia na ścieżce audio. Ścieżka danych jest dekodowana bez resamplowania, niezależnie od ustawienia częstotliwości w Sound Settings. Ba, możesz skompilować emulator --without-sound i też będzie działać.

    FUJI:

    A do Krótkiego na pewno się zgłoszę jak uznam że skończyłem ten etap (zapis do wav), choć się obawiam że sprawa znowu utknie przez brak czasu...

    Problem w tym, że Twoje zmiany są tak duże, że ich przegląd wymaga cholernie dużo czasu. Nie masz ty może u siebie jakiegoś git-repo, które byś mógł mi "wystawić", żebym sobie ściągnął i przejrzał zmiany rewizja po rewizji?
    • 35: CommentAuthorFUJI
    • CommentTime26 Feb 2017 zmieniony
     

    Krótki:

    FUJI, skoro jak widzę zacząłeś rozgryzać wersję 1010 - czy jest szansa, abyś uzupełnił Atariki o opis różnic w stosunku do wersji XC12?


    Oczywiście szansa jest, podobnie jak jest szansa na zintegrowanie moich zmian ;).

    Krótki:

    Jedyne co się resampluje to dźwięk do odtworzenia na ścieżce audio. Ścieżka danych jest dekodowana bez resamplowania, niezależnie od ustawienia częstotliwości w Sound Settings. Ba, możesz skompilować emulator --without-sound i też będzie działać.


    Źle się chyba wyraziłem z tym resamplowaniem, to był za duży skrót myślowy. Chodzi o to, że przy odczycie/zapisie połączonym z podsłuchem tego, co się dzieje na wejściu/wyjściu magnetofonu - a podsłuch jest synchronizowany z globalną częstotliwością dźwięku - coś przeszkadza w zachowaniu potrzebnej precyzji, tzn. nagranie zrobione w 192kHz nie chce się wczytać tak samo jak nie chce się wczytać nagranie w 64kHz. Dojdę w końcu o co biega. Pomysł z kompilacją --without-sound był świetny, dzięki. Jak się skompiluje bez dźwięku i ustawi częstotliwość nagrania na 160kHz, to AST dla 1010 działa zgodnie z przewidywaniem :).

    BTW - testuję szybkie AST dla 1010 przy użyciu cartridge-a którego dotyczy niniejszy wątek. Jak ktoś ma namiar na inny soft, który to obsługuje, jakieś loadery itp., to poproszę o info.

    Krótki:

    Problem w tym, że Twoje zmiany są tak duże, że ich przegląd wymaga cholernie dużo czasu. Nie masz ty może u siebie jakiegoś git-repo, które byś mógł mi "wystawić", żebym sobie ściągnął i przejrzał zmiany rewizja po rewizji?


    Jest coś takiego. Poprzednio już o to prosiłeś. Nawet podesłałem Ci linki do zarchiwizowanych repozytoriów. Po tamtym mailu kontakt się urwał - najpierw nie chciałem popędzać, potem sam zająłem się czym innym.
    Jak napisałem - zgłoszę się jak skończę to co chcę obecnie skończyć.
    • 36: CommentAuthoratariki50
    • CommentTime26 Feb 2017
     
    Panowie. Widzę że się DZIEJE historia. Trzymam kciuki:). Pilnuję tematu. Powodzenia.
    • 37: CommentAuthoratariki50
    • CommentTime26 Feb 2017
     
    Tylko proszę nie psprzeczajcie się o szczegóły ;). Cel uświęca środki. Czy jakoś tak :). W każdym razie ja czekam na efekty waszej pracy. Cierpliwie :). Powodzenia.
    • 38: CommentAuthoratariki50
    • CommentTime3 Mar 2017
     
    Bo widzę że temat spada.
    Wiem nie zaczyna się zdania od Bo :))
    Panowie, co tam słychać z AST?
    Jakiś krótki wpis mogę poprosić?
    Byłbym wdzięczny za odpowiedź.
    • 39: CommentAuthorFUJI
    • CommentTime3 Mar 2017
     
    Spokojnie, i tak poświęcam teraz na to większość wolnego czasu. Idzie jak trzeba. W weekend wrzucę wersję, która obsłuży turbo 2x szybsze niż AST 1010, jeżeli ktoś takie zdoła wymyślić ;).
    • 40: CommentAuthoratariki50
    • CommentTime4 Mar 2017
     
    No i fajnie:))
    To mnie uspokoiłeś ;)
    Powodzenia.

    Sam wymyśl, przecież praktycznie je tworzysz :)
    • 41: CommentAuthorFUJI
    • CommentTime5 Mar 2017
     
    Proszę. Poprawiłem precyzję zapisu, szczególnie dla wyższych częstotliwości plików wav. Teraz dane sterują słyszalnym dźwiękiem, a nie na odwrót. Jestem dość zadowolony z wyniku. Na ile zdołałem przetestować, to działają wszystkie systemy turbo widoczne w menu, zapis i odczyt. AST 1010 jest w tej chwili jako oddzielna pozycja tylko po to, żeby wyświetlić informację o wymaganiu co do częstotliwości.

    Linki te same co wyżej, powtarzam dla wygody.

    źródła liba8cas
    źródła atari800-a8cas
    binaria dla Windows
    • 42: CommentAuthormono
    • CommentTime5 Mar 2017 zmieniony
     
    Cenkju!

    Edit: Imponująca ilość systemów! Czy zostały w ogóle jakieś kasetowe turbo do oprogramowania? :D
    • 43:
       
      CommentAuthorbaktra
    • CommentTime5 Mar 2017
     
    Edit: Imponująca ilość systemów! Czy zostały w ogóle jakieś kasetowe turbo do oprogramowania? :D


    Wiele... :-)

    Rambit Turbo Tape, Chaos Turbo 6000, Turbo D, Turbo EMO, Turbo 2600, Injektor...

    FUJI, Dobra robota !
    • 44: CommentAuthorFUJI
    • CommentTime5 Mar 2017 zmieniony
     
    Chaos Turbo 6000 to chyba to samo co Turbo 6000 w emulatorze, a przynajmniej powinno tak samo działać.

    Dla Turbo 2600 zapis/odczyt działa na tej samej zasadzie co standardowy zapis/odczyt (FSK), więc nie nadaje się do menu turbo. Chyba, że mowa o jakimś innym, nie polskim Turbo 2600.

    Sistema Injektor działa na całkiem innej zasadzie niż PWM, do niego trzeba by dorobić oddzielny zestaw procedur, troche większa robota niż dodanie pozycji do menu.

    Pozostałych wymienionych nie znam, można sprawdzić czy działają po wybraniu innego systemu z menu.

    @Krótki - wysłałem maila.
    • 45: CommentAuthoratariki50
    • CommentTime7 Mar 2017
     
    Dobra robota, dzięki!!!
    Teraz tylko testować.
    A mówili że się nieda :))

    Może by tak link umieścić w menu naszej strony ?
    • 46: CommentAuthoratariki50
    • CommentTime11 Mar 2017 zmieniony
     
    I co cisza??
    Mam nadzieję że przed burzą.
    Nie wierzę że praca FUJI nikogo nie zainteresowała :(.
    Panowie trochę wpisów, ocen proszę.
    Tylko ja jestem zainteresowany tym emulatorem???

    Jeśli tak to piszcie. Nie będę zawracał gitary FUJI i Krótkiemu.

    Proszę o odzew !

    voy 27 Jan 2017
    @baktra: masz rację, działa w trybie AST. :)

    @FUJI: byłoby naprawdę super, nawet gdyby był tylko zapis do WAV. O zapisie do CAS nie śmiem marzyć, choć byłbym wielce kontent z zaistnienia takowej opcji. :)

    Przepraszam za tą wklejkę. Problemy techniczne tablet:).

    Ale mimo to proszę was o ocenę pracy FUJI i Krótkiego, ja jestem zadowolony a wy ???

    Voy, mono, baktra ???

    Napiszcie coś cholera :).
    • 47: CommentAuthorxtrem007
    • CommentTime12 Mar 2017 zmieniony
     
    Czy ktoś może mi podpowiedzieć jak poprawioną wersję atari800-a8cas skompilować dla RaspberryPi3? Z kompilacją biblioteki liba8cas sobie poradziłem. Kompilacja atari800 bez użycia --target=rpi kończy się sukcesem i w efekcie otrzymuję emulator który obsługuje systemy turbo ale nie obsługuje OpenGLES. Gdy kompiluję z parametrem --target=rpi otrzymuję komunikaty:

    checking for A8CAS_LIBS... -la8cas
    checking for A8CAS_CPPFLAGS...
    checking for liba8cas headers version >= 1.5.1... not present.
    checking for A8CAS_version in -la8cas... no
    configure: error: in `/home/pi/atari800-a8cas-writeturbowav/src':
    configure: error: unable to use liba8cas - the library was not found.

    Dlaczego przy kompilacji z parametrem --target=rpi konfigurator nie widzi biblioteki liba8cas?
    • 48: CommentAuthoratariki50
    • CommentTime7 dni temu
     
    Pisz do FUJI

    Albo ciągnij ten wątek. Ktoś kompetentny powinien się odezwać.

    Sam jestem zainteresowany :).

    FUJI

    Twój emulator żyje :).
    Pomożesz koledze?
    • 49: CommentAuthorFUJI
    • CommentTime7 dni temu zmieniony
     
    @xtrem007 - podeślij jakoś plik config.log, wskazówka jest w nim. Albo zajrzyj tam sam, może się zorientujesz o co chodzi. A kompilujesz bezpośrednio na rpi, czy pod linuksem dla rpi (cross compilation) ?
    Może masz gdzieś w systemie starszą wersję liba8cas ?
    • 50: CommentAuthoratariki50
    • CommentTime7 dni temu
     
    :)