atarionline.pl SIDE loader problem z ATR - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1: CommentAuthorarturkb
    • CommentTime13 Apr 2013
     
    Stałem się szczęśliwym posiadaczem SIDE2, zrobiłem partycje pod SDX oraz na pozostałe miejsce wrzuciłem całe archiwum AOL aby skorzystać z loadera. Pliki z rozszerzeniem XEX ładują się bez problemów natomiast np. ATR już nie pojawia się komunikat iż D1: not mounted, aborting booting. Nie wiem jak sobie z tym poradzić.
    • 2:
       
      CommentAuthorlotharek
    • CommentTime13 Apr 2013
     
    zamontowac ultimate
    • 3: CommentAuthoras...
    • CommentTime13 Apr 2013
     
    Aby sidem ładować atr-y trzeba mieć Ultimate...
    • 4: CommentAuthorarturkb
    • CommentTime13 Apr 2013
     
    macie na myśli Ultimate 1MB?
    • 5: CommentAuthorxxl
    • CommentTime13 Apr 2013
     
    byla juz o tym mowa:

    ->link<-
    • 6: CommentAuthorarturkb
    • CommentTime13 Apr 2013
     
    Faktycznie tym bardziej iż sam pytałem:). U1mb już nabyłem pozostaje zamontować. Dzięki za odpowiedź.
  1.  
    No dobra, to ja mam od paru dni zarówno SIDE2 jak i U1MB, ale dostaję taki sam komunikat: "D1: not mounted" oraz "No PBI driver found".

    Ustawienie konfiguracji Ultimate tak jak na filmie ze strony Lotharka powoduje, że nie wyświetla się SIDE loader tylko kolorowe krzaki.

    W wątku podanym przez xxl'a jest jest coś o flashowaniu ultimate, ale dałbym głowę, że Lotharek przy mnie bootował jakieś ATRy :) Tylko właśnie nie pamiętam, czy na swoim kompie, czy też na moim ze świeżo założonym Ultimate :)

    Jak tu jeszcze można zadziałać?
  2.  
    Trzeba w menu Ultimate'a wcisnąć i przytrzymać "L". I potem spacją można montować kolejne obrazy do napędów (potem przełączane guziczkiem).
  3.  
    Niestety, SIDE loader uruchamia mi się tylko wtedy, gdy w menu ultimate mam: "SIDE hardware: Disabled". Montowanie wtedy nie działa.

    Jak włączę SIDE w Ultimate to albo czarny ekran albo krzaki ;)
    • 10:
       
      CommentAuthorlotharek
    • CommentTime13 Nov 2013 zmieniony
     
    SIDE HARDWARE - ON WITH BUTTON ( nie "W/O BUTTON" _ WAZNE)
    SPARTA DOS - ENABLED

    S - jak SAVE
    C- cold boot

    restart, HELP + RESET --> menu ultimate, trzymamy L

    ps. na wszelki wypadek switch w side w gornej pozycji
  4.  
    Pojszło!
    Dzięki.
    • 12: CommentAuthorRocky
    • CommentTime13 Nov 2013
     
    ja mam inny problem.. sporo rzeczy się nie uruchamia prawidłowo.. zwłaszcza dem, które mają własne procedury sio (chyba).. np. halle project (ładuje 1 część potem error).. Czy jest na to jakieś lekarstwo?

    PS. Pewnie dotyczy to też wszystkiego z x-bios.

    Inna dziwna rzecz.
    SIDE2 ma własną spartę na pokładzie.. to po cholerę potrzebuje drugiej, która siedzi w ultimate??

    Pozdr
    • 13:
       
      CommentAuthorlotharek
    • CommentTime13 Nov 2013 zmieniony
     
    mgr_inz_rafal - pijemy ;-)

    ROcky : a jakbys nie mial ultimate ?

    z mojego punktu widzenia, dolozenie sdx nie podraza SIDE. no coz, moze tylko rtc troche podraza.

    i tak musi byc male cpld, i tak musi byc flash...a skoro jest, to czemu nie dolozyc ficzerow ?
    • 14: CommentAuthorxxl
    • CommentTime13 Nov 2013
     
    Moglby ktos sprawdzic czy capture the flag dziala z side? Chcialem w to zagrac, laduje sie ok ale po chwili grania zwiecha.
  5.  
    Jeszcze pytanie poboczne: czy loader SIDE można zmusić do załadowania kolejnej "porcji" plików z katalogu jeśli jest ich tam bardzo dużo? Na oko jest tam ograniczenie do dwustu kilku pozycji.

    Wolę zapytać zanim zacznę rzeźbić skrypt, który mi całe archiwum AOL na paczki podzieli, być może niepotrzebnie :)

    @xxl,
    Mogę sprawdzić jutro, tylko napisz, którą konkretnie wersję.
    • 16: CommentAuthorxxl
    • CommentTime13 Nov 2013
     
    wez dowolna wersje tej gry, jak bedzie Ci dzialac ok to zlinkuj, sobie pobiore.
  6.  
    Hej,
    Sprawdziłem dwie. Działają :)

    ->link<-

    ->link<-
    • 18:
       
      CommentAuthormgr_inz_rafal
    • CommentTime14 Nov 2013 zmieniony
     
    A jeśli chodzi o moje pytanie, to istotnie jest limit, jak to wyjaśnia sam autor:
    ->link<-

    Choć wg moich obliczeń robionych "na oko" jest on mniej więcej dwa razy mniejszy niż rzeczone 512 wpisów. Mogło się coś przez dwa lata zmienić :)
    • 19: CommentAuthorpin
    • CommentTime14 Nov 2013
     
    .. ja trzymam wszystko pod SDX.

    Ograniczenie jest takie:

    1423 wpisy na katalog. Powinno wystarczyć każdemu ;)
    • 20: CommentAuthorwilly
    • CommentTime14 Nov 2013
     
    Side Loader na sztywno ma ograniczenie do 250 (254?) pozycji.

    Jak masz ochotę możesz spróbować szybkiego loadera: ->link<-
  7.  
    @willy
    Jakoś mam wewnętrzne opory przed flaszowaniem czegokolwiek, zwłaszcza nowych zabawek przywiezionych parę dni temu z SV :)

    Napisałem sobie za to na szybko skrypt, który porządkuje pliki wg alfabetu i grupuje w paczki nie przekraczające X wpisów, jeśli zajdzie taka potrzeba. Dodatkowo dzieli je jeszcze na xex/atr bo trzeba różnie się do tych plików dobierać mając SIDE.

    Dla chętnych skrypt w załączniku (nie jest idiotoodporny, ani nic takiego).

    Przykładowy output dla archiwum AOL:
    *** Processing ATRs ***
    Scanning dir...
    7997 files found
    Sorting...
    Creating target dir...
    Moving files around...

    *** Processing XEXs ***
    Scanning dir...
    5961 files found
    Sorting...
    Creating target dir...
    Moving files around…


    Pozostaje czekać, aż pojawi się nowsza wersja archiwum gier, bo obecna jedzie już mocno naftaliną :)
    • 22: CommentAuthorRocky
    • CommentTime15 Nov 2013
     
    lotharek...

    Skoro w side jest sparta, to po co do wczytywaniu atrów trzeba włączać spartę w ultimate
    • 23: CommentAuthorstring
    • CommentTime4 Apr 2017 zmieniony
     
    Dlaczego swap ATR nie działa w side2?
    Mam najnowszy firmware ultimate 1.25 i uaktualnione Side 2. Przełącznik w side 2 w górnej pozycji. Sprawdzane na 800XL i XEGS. W menu ustawiona Sparta na enabled (sprawdzane też na disabled), PBI bios+hard disk+atr swap button - wszystko enabled.
    Loader ładowany na różne sposoby (z poziomu ultimate i side 2). Normalnie da się podmontować obrazy dysków pod D1 i D2 itd. Po wczytaniu dajmy na to Dallas Quest d1s1 wciskam przycisk na side 2 i START i nie wczytuje się z kolejnego dysku, tak jakby podpięty był cały czas pierwszy.
    Karta CF formatowana na różne sposoby, obecnie FAT32.
    Te obrazy dyskietek Dallas Quest normalnie działają na sio2sd.

    Dodam, że przed updatem firmware obu urządzeń wszystko działało ok.
    Przycisk oczywiście działa, bo resetuje komputer.
    • 24:
       
      CommentAuthorlarek
    • CommentTime4 Apr 2017
     
    Wszystko działa. Zaraz wkleję fotki z ustawieniami.
    • 25:
       
      CommentAuthorlarek
    • CommentTime4 Apr 2017 zmieniony
     
    • 26:
       
      CommentAuthorlarek
    • CommentTime4 Apr 2017 zmieniony
     
    W innych grach też nie możesz zmieniać dyskietek?

    string:

    Loader ładowany na różne sposoby (z poziomu ultimate i side 2).


    Loader z SIDE2 to nawet nie zobaczy plików ATR.
    • 27: CommentAuthorstring
    • CommentTime4 Apr 2017 zmieniony
     
    Larku, mam dokładnie tak samo. Niestety nie "łapie" drugiej dyskietki. Po swapowaniu na kolejną stronę dysku i wciśnięciu START, dioda na side2 raz mrugnie i dalej żąda dysku, tak jakby była dalej zamontowana pierwsza strona.

    Edit: tak. Przed chwilą próbowałem np z Pirates of The Barbary Cost. Jak pisałem te same obrazy na sio2sd działają poprawnie.

    Edit2: masz rację zapędziłem się z tym loaderem ATR uruchamianym z poziomu side.
    • 28:
       
      CommentAuthorlarek
    • CommentTime4 Apr 2017
     
    A czy przypadkiem nie uruchamiasz gry z dyskietki B?
    • 29:
       
      CommentAuthorlarek
    • CommentTime4 Apr 2017
     
    Dallas Quest uruchamia się bez problemu. Ładuje się pierwsza strona, żąda zmiany dysku - co robię przyciskiem na SIDE2 - i Start wczytuje grę. Problem opisany przez Ciebie pojawia się, gdy załaduję grę z dyskietki B. Dlatego pytałem o inne gry. Skoro na innych też jest problem, to nie wiem, co może być przyczyną.
    • 30: CommentAuthorstring
    • CommentTime4 Apr 2017 zmieniony
     
    Uruchamiam najpierw side A - wczytuje się pierwsza część gry, a potem podmontowuję side B oczywiście i dalej już nie wczytuje.

    Spróbuję ponownie sflashować Side.
    • 31:
       
      CommentAuthorlarek
    • CommentTime4 Apr 2017 zmieniony
     
    Rzuć okiem jeszcze tu: ->link<-
    Może w tym tkwi problem:

    kris2222:

    Alleluja!!! Działa!

    Problemem był Ultimate PBI bios. Nie wiem jak i co tam było wgrane wcześniej, bo upgradowałem całą paczką ultfull.rom. Po wgraniu oddzielnie ulpbi185.rom problem ustąpił.

    Wielkie dzięki za pomoc!
    • 32: CommentAuthormav
    • CommentTime4 Apr 2017
     
    U larka na filmie wszystko hula ;)
    • 33: CommentAuthorstring
    • CommentTime4 Apr 2017
     
    Zacytuję słowa krisa2222: "Alleluja!!! Działa!"

    Chociaż przez chwilę miałem większy problem. Uflash nie rozpoznawał Ultimate'a. Nawet po ustawieniu manualnym jego parametrów i próbie flasha chociażby podstawowego biosu, miałem: "Flash error! Retry?" i zwiecha.

    Dziękuję Larek.
    • 34: CommentAuthorstring
    • CommentTime6 Apr 2017
     
    To jeszcze jedna zagadka. Loader Ultimate 1MB wykrywa poprawnie kartę, katalogi i pliki na karcie CF umieszczonej w Side 2. Z kolei loader Side 2 wykrywa jedynie kartę, ale plików nie pokazuje (no entries). Dlaczego?
    Dodam, że stary firmware side 2 pokazywał zawartość karty.
    • 35:
       
      CommentAuthorlarek
    • CommentTime8 Apr 2017
     
    Masz więcej partycji na karcie?
    Generalnie to: nie wiem ;p
    • 36:
       
      CommentAuthorlotharek
    • CommentTime10 Apr 2017
     
    STRING - zmien 74ls08 na 74F08 na plycie atari
    • 37: CommentAuthorstring
    • CommentTime10 Apr 2017
     
    Dzięki, spróbuję to zrobić. A można widzieć czemu ma to służyć?
    • 38: CommentAuthorBarman
    • CommentTime16 Apr 2017
     
    @STRING

    Układy TTL serii LS (low power with shottky diode) teoretycznie powinny pracować poprawnie przy 25 MHz. W praktyce to LS'y przy 10 MHz mogą się nie wyrabiać. TTL-LS z racji tego że są low power to posiadają wyjścia które łatwo "przeciążyć" - wydolność takiej bramki to ok 8mA



    Natomiast układy TTL seri F (fast) mają pracować z częstotliwościami do 100MHz. Praktyka pokazała że w rzeczywistości dadzą radę i przy 120MHz o ile dobrze zostanie zaprojektowane PCB. Układy te nie są low power - obciążenie wyjścia to 20mA.
    • 39: CommentAuthorstring
    • CommentTime4 May 2017
     
    Po zamianie układu na ten w wersji fast wszystko działa jak należy. Dzięki.
    • 40: CommentAuthoraniol
    • CommentTime25 Aug 2017 zmieniony
     
    Pozwolę sobie na wykopek ;)

    Czy ktoś szanownych atarowców, posiadających SIDE2 i U1MB może sprawdzić, czy odpali mu się gierka A.E. z atrów?
    Przy wrzuceniu 2 obrazu - zwiecha. Na SIO2SD działa.
    Inne multi-atrowe gry działają, swap button działa... Ki czort?

    EDIT: demo Overmind nie chce wystartować. To są wyjątki od kompatybilności SIDE2?
    • 41:
       
      CommentAuthorlotharek
    • CommentTime6 Oct 2017
     
    skopany soft
    • 42: CommentAuthorxxl
    • CommentTime6 Oct 2017
     
    wyjatki od kompatybilnosci. nie beda dzialac programy, ktore jak ten musi byc uruchomiony z urzadzenia podlaczonego przez gniazdo Peripheral