atarionline.pl IDE Plus 2.0 rev C - problem z update biosu. - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1: CommentAuthorsun
    • CommentTime25 Jun 2020 zmieniony
     
    Mam Ci ja IDE Plus 2.0 rev C (kupiony jakoś z rok temu na znanym portalu), wpiąłem to do PBI w 800XL, zgłasza się bios w wersji 0.1 :) Myślę, zrobię update do 1.7a.
    A tu... Id 0 unrecognized, skipping. No IDE+2.0 devices found.
    I co z tym fantem? Próbować jakiś niżej, w sensie coś jakby po kolei jakieś wersje?
    Przyznam, że 0.1 to dość wczesna rewizja :) Ktoś chyba kupił i trzymał w szufladzie.

    edit:
    o tak, 1.0 chyba się wgra!
    Bus id: 0
    ROM id: 01A4
    jednak nie, chip erase, yes, failed ;(
    bez chip erase, programming stoi w miejscu.
    • 2: CommentAuthorpin
    • CommentTime25 Jun 2020 zmieniony
     
    Podpytam Draco co w tej sytuacji. Był chyba jakiś soft do ratowania takich sytuacji.

    Jak masz rozwiązaną kwestię zasilania interface'u?
    • 3: CommentAuthorsun
    • CommentTime25 Jun 2020 zmieniony
     
    hm, po prostu wpiąłem do PBI, nie zasilam go dodatkowo, mam kartę CF (nie uciągnie bez dodatkowego zasilania?) A jak odłączę kartę, też to chyba nic nie zmienia.
    W sensie, miałem nadzieję, że uda się go sfleszować.
    Tak, bez karty jest to samo, failed :(
    RTC działa, bateria sprawna z tego wniosek.
    Jakby ogólnie działa, ale... nie za bardzo.
    Do tego doczytałem właśnie, że mam kartę Transcend, a więc nie zobaczy albo zobaczy ale skaszani. No nic, na razie będzie wielki krok jak się jakoś da bios nowy/nowszy wgrać.

    czyżby to było to?
    RECOVER.BIN – a file you should burn (or flash) into a cartridge, if youhave to recover from a bad BIOS flash. Consult RECOVER.TXT for details.
  1.  
    Well,
    the 800XL does not have power (+5V) on the PBI, so you either need an external power supply or you must provide +5V at pin 47 or 48 of the PBI. Otherwise the IDE+2 will not work... maybe this is the reason why it is not detected ?

    (The 600XL has power on the PBI for the 1064 RAM enhancement, the 800XL has not since it already has 64k RAM.)
    • 5: CommentAuthorsun
    • CommentTime25 Jun 2020 zmieniony
     
    hmm.., you maybe right, but old bios10.com found interface (Bus id: 0, ROM id: 01A4), only flashing (chip erase, chip write) failed. On 130 XE machine external power supply is needed either?
    Screens from 800XL.
    • 6: CommentAuthorpin
    • CommentTime25 Jun 2020 zmieniony
     
    Masz Rapidusa w kompie? Jeśli tak, to przestaw ID NewDevice na #1. Na pcb interface'u jest taki obrotowy "kręciołek" z numerkami.
    • 7: CommentAuthorsun
    • CommentTime25 Jun 2020 zmieniony
     
    Nie, nie mam Rapidusa.
    Potrenuję Wasze porady, znaczy Twoją @pin i @CharlieChaplin z zasilaniem. Wcześniej jeszcze zobaczę co na to 130 XE. Zobaczymy.

    edit:
    W mojej rewizji C, nie mam pokrętła zmiany nr urządzenia PBI.
    • 8: CommentAuthorsun
    • CommentTime25 Jun 2020
     
    Dopytałem autora hardware i Simius potwierdził to co napisał CharlieChaplin. Lutuję zatem zasilanie +5V do PBI :)
    • 9: CommentAuthorpin
    • CommentTime26 Jun 2020 zmieniony
     
    ... nie doczytałem sprawy o zasilaniu, co jest dość oczywiste. Masakra ;)
    • 10: CommentAuthorsun
    • CommentTime26 Jun 2020
     
    zmyliło mnie to, że w ogóle wystartował, ale Simius mi to wytłumaczył :)
    • 11: CommentAuthorsun
    • CommentTime26 Jun 2020
     
    Zrobione, wgrał się bios 1.7.
    Dzięki za pomoc (w tym Simiusowi).
  2.  
    Quote:
    "On 130 XE machine external power supply is needed either?"

    The XE computers do have +5V on the cart. or ECI port, so an external power supply is not required (except you absolutely want an external power supply and/or have dozens of enhancements)...

    On the 800XL you can get +5V from anywhere on the motherboard, e.g. from the joystickports (make a cable from the joyport to the PBI)...
    • 13: CommentAuthorsun
    • CommentTime29 Jun 2020
     
    800 XL "patched" and working :) Now is time to expand RAM to 1 MB :)