atarionline.pl TOMS Multi Drive do ATARI 1050 - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1:
       
      CommentAuthorgaltron
    • CommentTime3 dni temu zmieniony
     
    Pszczoły już idą spać na zimę, więc znów jest więcej czasu na produkcję dodatków do małego ATARI 8bit. Właśnie odnowiłem produkcję Turbo TOP DRIVE do stacji ATARI 1050. Ciekawe jest też to, że postanowiłem zrobić mniejszą wersję i się udało co widać na zdjęciach.
    Idąc dalej tym tropem postanowiłem odkopać dawno nie używane Turbo do stacji ATARI 1050 jakim jest TOMS Multi Drive. Płytka zamówiona i na zdjęciu przedstawiam projekt płytki. Po przymiarkach w stacji płytka będzie się idealnie mieścić w miejscu gdzie wyciągniemy oryginalny EPROM oraz procesor 6507. Płytka będzie o wymiarach 55 x 53 mm.
    • 2:
       
      CommentAuthorgaltron
    • CommentTime3 dni temu
     
    • 3: CommentAuthoras...
    • CommentTime3 dni temu
     
    Chętnie bym zakupił multi drive do 1050.
    • 4:
       
      CommentAuthorJacques
    • CommentTime3 dni temu
     
    Ja też.
    • 5: CommentAuthorAlex
    • CommentTime2 dni temu
     
    Do 1050 to tylko Happy Warp :) Szkoda stacji na inne modyfikacje.
    • 6:
       
      CommentAuthorgaltron
    • CommentTime1 dzień temu
     
    @Alex - właśnie miałem HAPPY WARP 7.1 i się GAL posypał (jak to GAL). Nie jest to trwały element. Bez problemów działa TOP DRIVE a i TOMS Multi Drive też podobno jest OK. Robię testy od poniedziałku. Jak wszystko będzie dobrze to ruszy sprzedaż.
    • 7: CommentAuthorzaxon
    • CommentTime1 dzień temu
     
    No tak, dopiero co sie zebrałem to Top Drive założyć a ten tu z Tomsem wyskakuje , heheheh. Dobrze że z lenistwa 1050 nie skręcałem ;)
    • 8:
       
      CommentAuthorgaltron
    • CommentTime1 dzień temu
     
    @zaxon - Ty też masz tyle fajnych zabawek że życia by brakło żeby się tym wszystkim pobawić ;)
    • 9: CommentAuthorpirx
    • CommentTime1 dzień temu
     
    toms multi nejlepszi, bo tam nasz soft :]]]
    • 10:
       
      CommentAuthorgaltron
    • CommentTime1 dzień temu
     
    @prix - zaraz ktoś się upomni o prawa autorskie ;) Co ja wtedy zrobię ? ;)
    • 11: CommentAuthoras...
    • CommentTime1 dzień temu
     
    Zaxon sprzedaje klony Tomsów i jakoś nikt się nie upomina.
    Z Toms-ami nie ma kontaktu, próbowałem lata temu na różne sposoby.

    Duddie coś tam chyba działał w temacie multi, ale ani widu ani słychu?

    A klon Toms-a od Zaxon-a pierwsza klasa .!.
    • 12: CommentAuthorpin
    • CommentTime1 dzień temu
     
    @Pirx - ten co samowolnie formatował dyskietki? ;) Był jakiś tam taki epizod z Multi. Nie mogę sobie tylko przypomnieć w jakich okolicznościach.
    • 13: CommentAuthoras...
    • CommentTime1 dzień temu
     
    Q-meg, na Ultra spedzie.
    • 14: CommentAuthorpirx
    • CommentTime1 dzień temu
     
    beło beło, ale to w loduwie, a nie w 1050 :]
    (o ile pamiętam)
    • 15:
       
      CommentAuthorjhusak
    • CommentTime1 dzień temu
     
    Jest wirus na Atari, co samowolnie formatuje dyskietki. Może to to?
    • 16: CommentAuthorpirx
    • CommentTime1 dzień temu
     
    nie, to był jakiś race condition jak się wysyłało komendę "?" w inwersie czy coś, triggerował się format. trzeba było mieć ileś warunków spełnionych, żeby taka sytuacja zaszła, no ale cóż - zdarzało się.
    • 17:
       
      CommentAuthorgaltron
    • CommentTime23 godzin temu
     
    Tak, rozmawiałem z PECUŚ-iem który wnosił poprawki do softu ale ten problem dotyczył LDW2000 i CA2001. W Atari 1050 był już soft napisany na nowo i z poprawkami. Tak samo wyłączenie buforowania w A1050 jest proste bo wystarczy włączyć stację z opuszczoną dźwignią i już jest bez buforowania.
    • 18:
       
      CommentAuthorPecus
    • CommentTime18 godzin temu
     
    Okoliczności były takie, że Multi na LDW najpierw wykonywało przyjętą komendę, a potem sprawdzało jej sumę kontrolną :)
    I uwaga robiło tak zawsze - cud, że inne dziwne rzeczy się nie działy.

    A że składało sobie te bity do kupy bez pośrednictwa jakiegoś gotowego rozwiązania interfejsu szeregowego i do tego musiało obsługiwać kilka różnych prędkości transmisji, to jak spełniły się te warunki:
    - stacja czeka na rozkaz w Ultra Speed (poprzednia komunikacja odbyła się w US i zakończyła się poprawnie),
    - komputer odpytuje stację o prędkość w US wysyłając rozkaz "?" w standardowej prędkości (co QMEG robi przy pierwszej komunikacji z daną stacją po resecie)
    Stacja składając przychodzące bity danych (interpretując je z inną prędkością) uzyskuje rozkaz "!" w inwersie (oczywiście pozostałe bajty są śmieciami i suma kontrolna nie ma prawa się zgodzić, ale to wiadomo).

    No i teraz wchodzi do gry kolejna cecha Toms MULTI ... czyli jednoczesna obsługa turbo w standardzie TopDrive - fajna, ale to oznacza, że rokazy z ustawionym 7mym bitem (inverse) są interpretowane jako normalne rozkazy tylko w trybie TopDrive.

    I mamy format, bo "!" to właśnie rozkaz formatowania.

    MULTI dla 1050 tego błędu nie posiada.