atarionline.pl SDrive nie wczytuje niektórch gier - Forum Atarum

Jeśli chcesz wziąć udział w dyskusjach na forum - zaloguj się. Jeżeli nie masz loginu - poproś o członkostwo.

  • :
  • :

Vanilla 1.1.4 jest produktem Lussumo. Więcej informacji: Dokumentacja, Forum.

    • 1:
       
      CommentAuthorpiomet
    • CommentTime26 Mar 2017
     
    Proszę użytkowników SDrive o pomoc. Otóż nie mogę wczytać żadnej wersji River Raid przez SDrive która jest w katalogu gier na atarionline. Piszę o River Raid ale jest cała masa gier, która nie wchodzi. Gra się ładuje po czym albo komp wchodzi do Basic-a albo wisi.
    • 2: CommentAuthorQTZ
    • CommentTime26 Mar 2017
     
    Nie znam SDriv-a, ale objaw wskazuje na to, że nie wyłączasz Basic-a. Czyli nie trzymasz klawisza Option w odpowiednim momencie - czyli przy włączaniu Atari, lub/i przy uruchamianiu programu-gry, jak jest np. przy SIO2SD (stacji, etc.).

    BTW przy SIO2SD klawisze funkcyjne i Reset służą dodatkowo do przełączania trybu turbo, co wprowadza pewne zamieszanie i niestety wiele "tutoriali" błędne to pokazuje. A czy klawisze funkcyjne w SDrive mają jakieś dodatkowe funkcje nie wiem.
    • 3:
       
      CommentAuthorpiomet
    • CommentTime3 May 2017
     
    Przy włączaniu kompa jet option bo wchodzi menu SDrive i tu wybieram grę do załadowania. Gra ładuje się chwilę po czym jest zwiecha.Zaznaczam, że to gry z loaderem ze literą k w lewym górnym rogu.
    • 4: CommentAuthorxxl
    • CommentTime3 May 2017 zmieniony
     
    z tym loaderem moga byc przynajmniej dwa problemy: uzywa komorek na stronie zero i to dosc niefortunnych a takze niestety lokuje sie w miejscu gdzie dosc czesto laduja sie gry...

    ratunek: zamiast .xex znajdz ta gre w wersji .atr
    • 5:
       
      CommentAuthorpiomet
    • CommentTime3 May 2017
     
    OK spróbuję jak złożę atarkę. Z tego co pamiętam to możnabyło wybrac komórki gdzie ma się ładowac loader.
    • 6: CommentAuthorpin
    • CommentTime3 May 2017
     
    podeślij na pin(at)atari.pl gry plikowe w postaci pojedynczego zipa, zrobię z tego ATR i podlinkuję plik.
    • 7: CommentAuthorbob_er
    • CommentTime3 May 2017
     
    Z ciekawości - w które adresy na ZP ten loader się pakuje i w które obszary pamięci?
    • 8: CommentAuthorpin
    • CommentTime3 May 2017
     
    @piomet:

    sprawdź to:

    ->link<-
    • 9:
       
      CommentAuthorpiomet
    • CommentTime3 May 2017
     
    W manualu stoi:

    Built-in bootloader requiring less than 256 bytes including sector buffer, relocatable in the $0500-$05F7 to $BE00-$BEF7 range, with SKCTL initialization before every block. Supports executable files of up to 8MB size.
    • 10: CommentAuthorpin
    • CommentTime3 May 2017
     
    ok, ale to co podesłałem działa?

    Nie wiem tylko, jak tam wygląda boot z sdrive obrazu atr.
    • 11:
       
      CommentAuthorpiomet
    • CommentTime3 May 2017
     
    Dzisiaj już nie dam rady sprawdzić :( sorki.jutro zadzialam.dzięki.
    • 12: CommentAuthorpin
    • CommentTime3 May 2017
     
    luzik, daj znać co tam ciekawego z tego wynikło.
    • 13: CommentAuthorTomek79
    • CommentTime23 Jul 2021
     
    Cześć,
    właśnie kupiłem Sdrive i mam identyczny problem co piomet.
    Większość (90%) gier nie wczytuje się lub wczytuje się z błędem. Wybór plików ATR nic nie pomaga.

    Proszę o pomoc.
    • 14:
       
      CommentAuthorKaz
    • CommentTime23 Jul 2021 zmieniony
     
    Podrzuć przykład, gry, która Ci się nie ładuje - załącz tu plik na forum. Mam SDrive, więc mogę sprawdzić. Najczęstsza przyczyna - brak wciśniętego przycisku Option przy starcie, który to przycisk odłącza Basic.

    Masz SDrive Mini, SDrive, SDrive Max?
    • 15: CommentAuthorTomek79
    • CommentTime23 Jul 2021
     
    Sdrive mam ten:
    ->link<-

    Np. nie ładuje się ta gra:
    ->link<-

    1. Uruchamiam komputer z wciśniętym Option
    2. uruchamia się sdrive.atr
    3. wrzucam plik do D1.
    4. Naciskam Reset
    5. Wciskam i trzymam Option
    • 16:
       
      CommentAuthorKaz
    • CommentTime23 Jul 2021 zmieniony
     
    To urządzenie Zaxona. Mam gdzieś, ale muszę poszukać. Na razie sprawdziłem na SDrive Max, wszystko działa. Akurat podczas wczytywania wyłącza dźwięk transmisji, może to Cię zmyliło?

    PS. Sprawdziłem też na moim SDrive Mini od Zaxona, gra ładuje się i działa znakomicie.
    • 17: CommentAuthorTomek79
    • CommentTime23 Jul 2021
     
    Trzymam Option wciśnięty bardzo długo.

    Próbowałem nawet z grą Gyruss:
    ->link<-

    Tą którą uruchamia na tym filmiku:


    Trzymam Option i trzymam. Gdy kończy się dźwięk ładowania to pojawia się czarny ekran. Gra się nie wczytuje :(
    • 18: CommentAuthorpirx
    • CommentTime24 Jul 2021
     
    może to słaba podpowiedź, ale spróbuj może najpierw trzymać option, potem wcisnąć reset?
    nie wiem, czy tak się da w sdrive mini, może option coś robi?

    spróbuj uruchomić w basicu taki programik:

    10?PEEK(53279):G.10
    RUN

    zobacz, czy jak wciskasz opition to się zmienia 7 na 6
    • 19: CommentAuthorTomek79
    • CommentTime24 Jul 2021
     
    Dzięki za podpowiedź,
    nie zmienia się na "6".
    Nie mogę też uruchomić SELF-TESTU z wciśniętym Optionem (sdrive wyciagnięte).
    Gdy uruchamiam SELF-TEST komendą BYE - to nie mogę wybrać nic używając SELECT ani uruchomić wciskając START.
    Wniosek: nie działa START, SELECT, OPTION.
    Czy HELP też nie działa- nie wiem, jak to sprawdzić?
    I najważniejsze pytanie kto może mi to naprawić? :)
    • 20: CommentAuthor_kriss_
    • CommentTime24 Jul 2021
     
    Folia klawiatury do wymiany
    • 21: CommentAuthorPeri Noid
    • CommentTime24 Jul 2021
     
    Ewentualnie do naprawy, jeśli to tylko jedna ścieżka. Trzeba rozebrać i obejrzeć.
    • 22: CommentAuthorTomek79
    • CommentTime24 Jul 2021
     
    Dziękuję. Rozkręcę klawiaturę i dam znać.
    • 23: CommentAuthorTomek79
    • CommentTime24 Jul 2021
     
    Tak oto wygląda folia
    • 24: CommentAuthorPeri Noid
    • CommentTime24 Jul 2021
     
    Popatrz na schemat połączeń na folii (schematy komputera np. na stronie Jera), znajdź ścieżkę wspólną dla klawiszy funkcyjnych a potem ją prześledź od gniazda do końca. Szukaj miejsc zaczernionych (utlenionych), przerwanych albo wyglądających inaczej niż powinny.
    • 25: CommentAuthorpirx
    • CommentTime24 Jul 2021 zmieniony
     
    brzeg tej folii, szczególnie po prawej stronie zdjęcia, wygląda źle (a jak widać, to właśnie te ścieżki idą do klawiszy funkcyjnych). po drugiej stronie też nie najlepiej. są jakieś farby przewodzące, można próbować naprawiać, jeśli masz cierpliwość.
    • 26:
       
      CommentAuthorjhusak
    • CommentTime25 Jul 2021 zmieniony
     
    ZANIM zmontujesz:

    Klej/lakier przewodzący na bazie srebra robi robotę, tylko trochę długo schnie.
    Można sprawdzić czy help działa uruchamiając self test, poczekać aż się uruchomi automatycznie i jeśli help działa, to po naciśnięciu powróci do menu.

    Natomiast nie sądzę, że działa, może najwyżej działać reset; zwróć uwagę na górnej części za resetem jest czarny prążek, może to tam jest przerwa. Miernik na zwarcie ustawiony i do dzieła!
    • 27: CommentAuthorPeri Noid
    • CommentTime25 Jul 2021
     
    Jedną ścieżkę da radę naprawić. Ale jak to kwestia kilku koło siebie to trudno go odpowiednio rozprowadzić. Chyba lepiej membranę od Simiusa kupić.
    • 28: CommentAuthorzaxon
    • CommentTime26 Jul 2021
     
    @Tomek79 , pisaliśmy o tym jakiś czas temu. Zdiagnozowałem ci problem. Podałem linka gdzie możesz kupić nowa folię. Tu widzę jednak mi nie wierzysz i wolisz się zapytać o drugą opinię ;)
    Tak jak ci pisałem, możesz "zaoszczędzić" , kupić klej na bazie srebra, dobry klej to koszt połowy nowej folii ;) A byle jaki nic nie da... Upaćkać sie tym, porozmazywać, stracić 2 dni na bezsensowną robotę .
    Można też kupić nową membranę, zamontować i mieć spokój na lata...
    No ale jak tam komu wygodniej ;)
    • 29: CommentAuthortakron27
    • CommentTime27 Jul 2021
     
    ja czasem drobne ubytki naprawiam lakierem, ale co to, to do tego bym się nie brał za chiny. wygląda, jakby co parę tygodni miała zdechnąć jakaś kolejna ścieżka.
    • 30: CommentAuthorTomek79
    • CommentTime3 Aug 2021
     
    Dziękuję wszystkim za pomoc.

    @zaxon - to nie tak, ze ci nie wierzę :) po prostu jednocześnie zapytałem ciebie i umieściłem też pytanie tu na forum.
    Jest wręcz odwrotnie - posłuchał się ciebie i zamówiłem nową folię. Dzięki!

    Nowa folia już jutro do mnie dotrze.
    Jako, iż z elektroniką jestem na bakier (hobbistycznie robię w drewnie ;)
    mam pytanie:
    W jaki sposób odłączyć starą folię od płyty?
    Zaznaczyłem to miejsce na załączonym zdjęciu.
    Czy mam na siłę wyciągnąć ją z tego czarnego złącza?
    Czy to czarne złącze mam wypiąć (jak?) z płyty?
    • 31: CommentAuthorPeri Noid
    • CommentTime3 Aug 2021
     
    Po prostu ciągniesz prostopadle do płyty. Wyjdzie.
    • 32: CommentAuthorTomek79
    • CommentTime3 Aug 2021
     
    Ale ma wyjść folia z czarnego złącza?
    czy czarne złącze z płyty?
  1.  
    Folia z czarnego złącza.
    • 34: CommentAuthorTomek79
    • CommentTime4 Aug 2021
     
    Po wymianie foli wszystko działa poprawnie.

    Jeszcze raz dziękuję wszystkim za pomoc.

    Bardzo się cieszę. To bezcenne móc pokazać synkowi na jakim komputerze i w co grałem gdy miałem tak jak on 9 lat :)